iw3mp problem

Thread started by sHarK! on Tuesday, 6:20pm September 1st with 11 replies. Views: 682

sHarK!
Posts: 91
Level: BRONZE
Reputation:
Hey guys I recently bought the game from steam since i wanted to play some matches, obviously as it always was, cod4 is not really the most user friendly game evah. I used to be able to handle the accuring problems with the game but i didnt touch the game for 7 months now and i forgot how to solve these problems.

My question is what to do when you get the following error --> the iw3mp exe stopped working.

thank you for your help.
Posted 6:20pm Sep 1st 15
sjappiii
Posts: 865
Level: BRONZE
Reputation:
replug your headset
solved / close pls
Posted 6:25pm Sep 1st 15
sHarK!
Posts: 91
Level: BRONZE
Reputation:
does this mean that the problem can occur even if i have no headset plugged in?
Posted 6:31pm Sep 1st 15
Migii86
Posts: 1,064
Level: BRONZE
Reputation:
There are few methods to fix this:
1)Reinstall cod4.

2)Uninstall the sound card drivers for realtek and other similar cards and install the default driver on the PC.
How to do so:
a)Open Start menu, select Run, type sysdm.cpl and then press Enter to display the System Properties dialog box.
b)On the Hardware tab, Device Manager.
c)In the Device Manager window, expand Sound, video, and game controllers.
d)Right-click the sound card driver and then select Uninstall.

3)Install required updates such as patches (install all of'em once again).If you are running the game on a secondary partition, you may have to download the latest BIOS updates from your motherboard manufacturer and follow the other applicable solutions posted.

4)Use headphones if you already aren't.

5)Enabling the Stereo mix
How to do so:
Start>Control Panel>Double click on the Sound Tool>Click on the recording tab>
Right click and select "View Disabled Devices">Enable the Stereo Mix

6)Rename the Mssmp3.asi File
How to do so:
Locate mssmp3.asi, by default, located in the C:\Program Files\Activision\Call of Duty 4 - Modern Warfare\miles\ folder. Rename mssmp3.asi to mssmp3.bak.

7) Try to re-plug the microphone in your mic-jack (i know it sounds weird but it could work and i saw people listing this as a solution.

8)If you're playing on Windows 8 switch to Windows 7 :D

Best of luck and you're welcome.
Posted 6:34pm Sep 1st 15
direeX
Posts: 48
Level: BRONZE
Reputation:
5)Enabling the Stereo mix
How to do so:
Start>Control Panel>Double click on the Sound Tool>Click on the recording tab>
Right click and select "View Disabled Devices">Enable the Stereo Mix

this will solve this
Posted 6:36pm Sep 1st 15
sHarK!
Posts: 91
Level: BRONZE
Reputation:
thank you:)
Posted 6:36pm Sep 1st 15
Migii86
Posts: 1,064
Level: BRONZE
Reputation:
fixed the problem yet?
Posted 7:13pm Sep 1st 15
myss
Posts: 1,426
Level: PLATINUM
Reputation:
When people fix the problem, it would be good to tell how exactly they fixed it, someone else might be having same problem in a future.
Posted 7:17pm Sep 1st 15
supMEH
Posts: 1,133
Level: BRONZE
Reputation:


When people fix the problem, it would be good to tell how exactly they fixed it, someone else might be having same problem in a future.

Quote from miss on the 1st of September 2015
5)Enabling the Stereo mix
How to do so:
Start>Control Panel>Double click on the Sound Tool>Click on the recording tab>
Right click and select "View Disabled Devices">Enable the Stereo Mi

This is not enought for u ?
Posted 7:19pm Sep 1st 15
myss
Posts: 1,426
Level: PLATINUM
Reputation:
There were several things offered here, writing thank you after them might be polite but it isn't very straightforward answer.
Posted 7:21pm Sep 1st 15
sHarK!
Posts: 91
Level: BRONZE
Reputation:
jeah i need some time to try them all, i didnt manage to fix it yet.
Posted 7:27pm Sep 1st 15
sHarK!
Posts: 91
Level: BRONZE
Reputation:
Alright so guys its fixed thnx for the help, i didnt have my headset plugged in that was all.

I plugged in then restarted the PC and it is working now.
Posted 7:56pm Sep 1st 15